在ubuntu 16.04安装ROS Kinetic ,“软件包有未满足的依赖关系”错误

下列软件包有未满足的依赖关系:
ros-kinetic-desktop-full :
依赖: ros-kinetic-desktop 但是它将不会被安装
依赖: ros-kinetic-perception 但是它将不会被安装
依赖: ros-kinetic-simulators 但是它将不会被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

 sudo apt-get update
 sudo apt-get install ros-kinetic-desktop  ros-kinetic-perception ros-kinetic-simulators

然后重新安装:

sudo apt-get install ros-kinetic-desktop-full
已标记关键词 清除标记
相关推荐
©️2020 CSDN 皮肤主题: 点我我会动 设计师:白松林 返回首页